Jump to content
Sign in to follow this  
SteveHTN

Loose connector Bird 1198

Recommended Posts

I’ve got an 1198 at my console. The power and transducer plug both fit kinda loose, so sometime it’ll shutoff on me if I hit a bump. Any ideas, besides buying a new Helix 9?

Share this post


Link to post
Share on other sites

Sounds like a job for my favorite thing ever..... Black tape!!! Don't do that unless you want to look extra redneck like me. I would say maybe replace the cables but that may not improve things if the female receptor is the problem

Share this post


Link to post
Share on other sites
On ‎1‎/‎28‎/‎2019 at 5:13 AM, rusty50576 said:

Sounds like a job for my favorite thing ever..... Black tape!!! Don't do that unless you want to look extra redneck like me. I would say maybe replace the cables but that may not improve things if the female receptor is the problem

Non hardening silicone. Put some on your finger and put a thin coating of it on the outer rim of the plug that inserts into the unit. Make sure you don't put so much on that it interferes with your plug connections. Let it set up a few minutes and you should be good to go. Had that issue a couple times in the past and the silicone worked fine.

Edited by softbaitmaker
  • Like 1

Share this post


Link to post
Share on other sites

Yep, pretty common problem with older birds. Mine did the same thing. Bend the prongs on the power cord SLIGHTLY! To insure they are making contact at all times. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Who's Online   0 Members, 0 Anonymous, 1 Guest (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

×